XboxAchievements Got a news tip?

Go Back > > > >
Subscribe    Donate

Thread Tools Display Modes
Old November 14th, 2011, 08:02 AM   #11
RainDeadMaker's Avatar
Join Date: Dec 2009
Posts: 31

It glitched on me at race 3 of Race Series IX. At first it loaded and I was driving slowmo but the time was real-time. I quit the race, redid the others up to this race again. Race was fine until the end, it glitched to the XMB...I was pissed cause I got all the corners in that race and didn't save. Redid that series like 5 times til I finally got past that race completely to finish the series. I didn't delete the game data but was about to!! Hope people get through the glitches before corrupting their controllers with floor data...
RainDeadMaker is offline   Reply With Quote
Old December 11th, 2011, 11:53 AM   #12
fpsd0minat0r's Avatar
Join Date: Oct 2011
Location: UK
Posts: 413

omfg this takes the f***ing p**s. I completed ALL of the races with all stars but after i finished nordschleife it quit to xmb. I checked my progress and i have all stars except for the last race. i tried playing it and it wants me to play all the other races as well.
f**k you EA, if it wasnt for trophies i would never play this piece of s**t.
fpsd0minat0r is offline   Reply With Quote
Old April 10th, 2012, 11:00 PM   #13
chizzum18's Avatar
Join Date: Oct 2009
Location: The Ganja Bus
Posts: 852

Yes, this has happened to me. Exact same race as you. Same thing, after the third race, I hit x and then it just automatically quit to the XMB. I shut the system off for the night, and the next time I tried, it worked fine. It has never happened to me since. But that is really weird though.
chizzum18 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT. The time now is 08:17 PM.